Background

This site no longer runs on my browser, Safari 8.0.8, in a way that allows me navigate the site with usual navigation buttons found on the top of each page of the site. As of today, some of the buttons no longer appear and the ones that do don't execute properly when I click on them. They were all present and worked fine yesterday.

My browser, although old, is only having problems with SE sites. It does not misbehave on any of the other sites I visit. For instance, in constrast to SE sites, I have no problems at all when I sign into the Wolfram Community site. The problems stated a couple of months ago and have steadily gotten worse. They have reached the point where I feel I can no longer meaningfully participate. For example, to post this question I had to enter the URL

https://mathematica.meta.stackexchange.com/questions/ask

into Sarfari's search field. I not could use any of the usual navigation controls to reach Meta's Ask Question page.

I am working on up-grading my computer's OS from OS X 10.10.5 to OS X 10.13.3. This is a time consuming effort, but it will certainly give me the latest version of Apple's Safari browser and, perhaps, may fix my problems. I certainly hope so. If it does, I will be back. Otherwise, this is goodbye.

Question

Can anybody tell me what versions of Safari are supported on this site? Alternatively, can anybody tell me where to go in the SE environment to get this information?

I ask this in the hope that there is an interim version of Safari that will run on mu current OS X 10.10.5 system and will enable me to remain in touch with Mathematics.SE community until I finally get OS X 10.13.3 up and running.

  • I have no knowledge of Safari. However, I had a similar sounding problem with IE11 on Windows 10. It turned out that somehow my SE settings were changed from PC to smart phone. Changing the setting back solved the problem. I am sorry that I do not recall more. – bbgodfrey Mar 28 at 0:21
up vote 3 down vote accepted

On meta.SE, they state that

...we support the last two versions of the browsers that we see the vast majority of our visitors actually use. This does not include beta/dev releases, which are not supported.

Going by that, and this version history for Safari, it seems version 8 is not expected to work smoothly with Stack Exchange anymore, so you'd have to upgrade.

  • I was afraid that would be the answer. <sigh>. Other sites seem to be supportive of older browsers like mine. – m_goldberg Mar 28 at 2:10

I am posting this self-answer to give closure to my question.

I have completed upgrading from OS X 10.10.5 (Yosemite) to macOS 10.13.4 (High Sierra). It was a very big pain, but I am now browsing with Safari 11.1 and all my problems with this site have vanished.

And, yes, Apple changed the name of its OS in the three years between my install of Yosemite and my install of High Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .