Today, when I tried to edit a question, I found Halirutan's button bar had disappeared from the input editor. It still appears and works on the Ask Question page, so I know it's not my browser that's malfunctioning.

Can we get the management to fix this?

Edit

Since I posted this question, for me the button bar has also disappeared on Ask Question page.

Here is some data concerning my browser environment.

Safari
Version 8.0.3 (10600.3.18)

Name: NinjaKit
Version: ver 0.9.1
Author: os0x

Javascript
// @name          Mathematica Toolbar Buttons
// @author        Nathan Osman, Patrick Scheibe
// @version       1.3.8

And here is how the code editor looks to me.

I sure hope this can be fixed, either at my end or at the SE end. I feel lost without the button bar.

code_editor

Update

Good news and bad news. The good news that Halirutan's buttons have been restored to me for all edit panes which supported them in the past. The bad news is that the edit panes now look like this:

editor

What the ... is going on? I know the SE people are constantly monkeying with -- er, excuse me, that should be "improving" -- the site, but why are these site changes affecting me, and apparently only me, in this way?

I realize I am using a very old version of Safari. I can't install an up-to-date version until I update my version of OS X. I plan to do that as soon as I can, but meanwhile it is a pain to endure these little surprises as they hit me one after another.

  • You scared me, but fortunately it still works for me. Have you resolved your issue? – corey979 Feb 9 at 19:07
  • @corey979. No, I'm still clueless. – m_goldberg Feb 9 at 19:56
  • Did you try another browser? Chrome, FF? I mean to check if it's a browser issue, an OS issue or sth. – corey979 Feb 9 at 19:58
  • @corey979. I tried Chrome. I found I don't like it, but it did give me a helpful message that Safari didn't. I went back to Safari, signed out of SE, restarted Safari and there was some improvement -- I once again see buttons on the editor tool bar on the Ask Question page, but not on any other pages. – m_goldberg Feb 9 at 21:25
  • I'm really clueless what to do about this. I only use Chrome, so I cannot be of any help for Safari. @m_goldberg what exact Safari version are you using now? The only way I see at the moment is that someone with your Safari version and with at least some experience in JavaScript steps out to debug it. – halirutan Feb 26 at 9:42
  • @halirutan. Version of Safari given in the post. I have concluded that your JavaScript code for the buttons is a not the issue. The editor tool bar vertical formatting appears even on pages where your buttons don't appear, such as review queue pages. IMHO it is changes made to site code by SE site developers that is the cause, so I agree you can't help. And no help is really needed because the buttons are working again. I posted the my most recent rant about the latest change just to keep people following my post up to date :-) – m_goldberg Feb 26 at 22:44

Aux contraire! Just tried it and for me it is still there:

img

Hmm.. very odd. How can we find the source of this?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .