1

This is really more of a request, but would it be possible to implement a simple spell-check when asking / answering questions, excluding constructions within MathJax environment? I think it may cut down on number of the minor reviews necessary, help non-English speakers, and dyslexic people, as well as helping people who type carelessly (like me unfortunately!) - especially for long Q/A? Sloppy spelling often gets in the way of the key message of the question, which of course is the main point of SE. It would be nice if such a feature existed, with option to turn off if desired.

2
  • 2
    I am going to decline this as status-bydesign because, as you noted, this is more an issue with the browser rather than something we would implement on this system specifically. Jun 29, 2015 at 18:41
  • @RobertCartaino sure - I just voted to close too, rather than delete as I think halirutan's answer & Mr.Wizard's comments are a useful ref. :)
    – martin
    Jun 29, 2015 at 19:52

1 Answer 1

7

Well, actually spell-check should work inside your browser. It would be counterproductive to include it to SE because there are sites that are multilingual (like German-Language SE). Why don't you just turn it on inside your browser, then you probably see your that you misspelled "implement" :D

enter image description here

16
  • ah, so this is a browser issue rather than an SE one. I use Firefox, and have schecked options though couldn't find anything :/
    – martin
    Jun 19, 2015 at 13:18
  • @martin Look at this here. That should help you with FF.
    – halirutan Mod
    Jun 19, 2015 at 13:23
  • that is strange - it is turned on already :/
    – martin
    Jun 19, 2015 at 13:30
  • thanks for pointing out "implement" BTW!!!
    – martin
    Jun 19, 2015 at 13:31
  • 1
    Hmm, that's indeed strange. I use Chrome and cannot really help you, but I'm relying on spell check very much too.
    – halirutan Mod
    Jun 19, 2015 at 13:33
  • I'll look into it - may haver to reset FF or something ...
    – martin
    Jun 19, 2015 at 13:49
  • @martin If you right-click in editor field is Check Spelling tickmarked within the context menu that comes up?
    – Mr.Wizard
    Jun 19, 2015 at 20:40
  • @Mr.Wizard If you mean in Mathematica SE, no, it isn't (I'm not sure I get a context menu). If you mean in Firefox, I can't see a context menu ...
    – martin
    Jun 19, 2015 at 21:35
  • @martin I mean in Firefox. Nothing happens when you right-click within the editor area? You should see something like this: i.stack.imgur.com/e2kcb.png
    – Mr.Wizard
    Jun 19, 2015 at 21:39
  • @Mr.Wizard no - just cut, copy, etc + Inspect Element. Do I need another addon or something?
    – martin
    Jun 19, 2015 at 21:42
  • @martin As far as I can recall it should be built-in. Please type about:config into the location bar and press return. (Accept "I'll be careful" or whatever warning it is if you get one.) Then type layout.spell in the Search field. You should see an item layout.spellcheckDefault -- what is the Value set to?
    – Mr.Wizard
    Jun 19, 2015 at 21:51
  • @Mr.Wizard it is set to 1
    – martin
    Jun 19, 2015 at 21:59
  • @martin Try setting it to 2 and see if anything changes.
    – Mr.Wizard
    Jun 19, 2015 at 22:03
  • @Mr.Wizard no, set it to 2, then restarted FF, still nothing :(
    – martin
    Jun 19, 2015 at 22:09
  • @martin Sorry, I'm out of ideas. I suggest you take this to a Firefox forum, or perhaps SuperUser.
    – Mr.Wizard
    Jun 19, 2015 at 22:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .